Long pending transactions on Custody API
Incident Report for Tangany
Resolved
Issue resolution time: 17:06:2023 09:29:00 AM CET

Impacted Services: All supported network transactions on Custody API v1.

Root cause: Long processing time caused transactions to pile up on supported networks of Custody API, necessary actions are taken to push the pending transactions in the queue, all async processes / pending transactions are completed.

Recovery: The impacted services are back to functional after necessary steps was taken on the infrastructure side. This cleared all the pending transactions waiting in the queue. All supported networks on Custody API v1 are working as expected.
Posted Jun 19, 2023 - 15:39 CEST
Update
We are continuing to investigate this issue.
Posted Jun 15, 2023 - 11:10 CEST
Update
We are continuing to investigate this issue.
Posted Jun 15, 2023 - 11:05 CEST
Update
We are continuing to investigate this issue.
Posted Jun 15, 2023 - 11:03 CEST
Investigating
We noticed long pending transactions on custody API starting 14:06:2023 16:00:00 UTC.
Response:
{
'process': 'Pending',
'status': None,
'created': '2023-06-14T23:00:50Z',
'updated': '2023-06-14T23:00:50Z',
'output': None
}

Issue start time: 14:06:2023 16:00:00 UTC

Severity: 2 PARTIAL OUTAGE

Impacted Services: Custody API transactions are pending.

We identify the possible cause of this issue and are working on bringing the service back as soon as possible. Thank you for your patience.
Posted Jun 15, 2023 - 10:57 CEST
This incident affected: Tangany Custody API (API backend, Ethereum Mainnet, Ethereum Goerli, Ethereum Sepolia, Polygon Mainnet, BNB Chain Mainnet, Bitcoin Mainnet, Bitcoin Testnet, Tezos Mainnet).