CUSTOMER API-DELETION request Error
Incident Report for Tangany
Resolved
The issue has been resolved. We apologize for any inconvenience. Kindly find the below summary.

Incident summary: Deletion of entities on Customers API is failing due to degraded performances

Issue start time: 10:00, 04 Aug 2023 Friday

Issue resolution time: 14:00, 04 Aug 2023 Friday

Impacted Services: Customer API v2 (Delete Call)

Root cause: Indexing on tables triggered the performance issue on deletion.

Recovery: The issue has been resolved by improving the table indexing and optimizing table logs data checks.
Posted Aug 04, 2023 - 16:41 CEST
Monitoring
The issue has been fixed and all services of customers API are working as expected. We are continuing to monitor the services.

End date: 04.08.2023 Fri 14:00:00 CET
Posted Aug 04, 2023 - 14:27 CEST
Identified
We have identified that due to an issue with traffic on the Database level there was some latency in the deletion of entities on Customers API, which led to degraded performances on Customers API. This issue was fixed by our technical experts and all endpoints now on Customers API are fully operational.
Posted Aug 04, 2023 - 14:24 CEST
Investigating
We are experiencing a technical issue with our services CUSTOMER API. We apologize for the disruption.
Our engineers are working on restoring the service as soon as possible, and we will provide updates on the service status here.

Please bear with us while we work through this disruption to your account. If you have any questions, please get in touch with us at support@tangany.com

Activity start time: 10:00, 04 Aug 2023 Friday

Activity End time: TBD

Next update in 2 hrs
Posted Aug 04, 2023 - 12:10 CEST
This incident affected: Tangany Customers API (API backend).